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By JP Kabala

Series Introduction
I know it is hard to believe, but once upon a time, software programs really didn’t have any built-in way

to fix your mistakes. (Yes, I’m really old enough to remember those scary days!) Then, way back in the

days of DOS, someone decided that it would be a good thing if you had a way to step back and “un-do”

the command you’d just issued, and CTRL+Z or Undo was born.  Lots of people started liking comput-

ers a lot more as a result. 

As programs became more sophisticated, they allowed users to turn back the clock more and more–

three levels of undo, ten levels of undo, and so on.  But users still wanted more control over their results. 

And Jasc listened, and delivered. For several versions, Paint Shop Pro had a very nice way to undo (or

redo) many sequential commands at once. This feature was called the Command History. 

When the Command History was chosen from the Edit menu, users were presented with a list of the

operations that had been performed on the image in reverse order (most recent first). It listed the action

number, amount of time since you performed the action, and the command performed. To undo or redo

many commands at once, the user selected a command to undo or redo, the program automatically

selected all the commands above it.  
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It was very useful, but there were still limitations. It was good, but it wasn’t the “Back to the Future Time

Machine” of many users’ dreams.  In earlier versions of Paint Shop Pro, in order to undo or redo a com-

mand, you had to undo all the operations that appeared above it on the list. So, in the example shown

above, there was no way to undo the Colorize step without redoing the Rotate and Polar Coordinates

steps.

So Jasc was still listening and working on improving the software, and in Paint Shop Pro 9, the

Command History has been replaced by the new, more powerful and flexible History Palette, and you

have more options than ever.  Like its predecessor (the Command History), the History Palette will not

interfere with using the Standard toolbar Undo icon or the keyboard command CTRL+Z in the usual

manner to quickly undo recent mistakes. Instead, it might help to think of it as a power tool that remem-

bers all the steps taken in your image and lets you undo several at once, undo one command while later

commands remain in force, and convert a sequence of commands to a temporary script (called a Quick

Script) that you can apply with a single click to the current image, or any other image. You can even drag

and drop commands, complete with all their settings, to other images!

The History Palette and its Toolbar Icons
By default, when Paint Shop Pro 9 is installed, the History Palette is docked to the lower right side of the

screen, below the Materials Palette. If you have closed or hidden the History Palette, you can toggle the

visibility by pressing the F3 key or by choosing  View > Palettes > History.

The Image above shows the exact same sequence of commands that were executed in Paint Shop Pro

8 as they would appear in Paint Shop Pro 9’s History Palette. If it looks a little more complicated, that’s

because you have so many more options. 
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Since there is so much excellent background information on the History Palette in your User Guide,

online Help, and Learning Center, I won’t repeat all that information here. Instead, we’re going to con-

centrate on the practical application of two of the most powerful and useful new features of the History

Palette--Quick Scripts and Selective Undo. We’re going to do a few simple exercises to help you under-

stand how to take advantage of these options to fix mistakes, improve productivity, and even create

special effects.

There are many unfamiliar-looking icons and symbols on the new History palette. The illustration shown

provides a quick reference to the strip of icons that appear along the top and clarifies the meaning of the

three states of the “eye” icon that appears before each command on the left side of the palette. 

Note: If your History Palette is docked in the default position, you may not be able to see some icons. 

You may, instead, see a small, rightward-pointing triangle on the right edge of the palette. Simply 

enlarge the palette or undock it to see the hidden icons.

Here are some of the more common uses of these features:

■ To Undo or Redo a single command: Click the “eye” icon at the left of the entry. 

Paint Shop Pro will show an X through the icon beside any commands which have been 

undone, whether via the History Palette, toolbar icon, or keystroke. 

■ To selectively undo a command without influencing others in the sequence: use 

CTRL+Click. A yellow X indicates an undone action or command. A red X indicates a 

selectively undone action or command that left subsequent commands in place. 

■ To Undo or Redo several commands at once: Click the first command in the series that 

you want to change and then click the Undo or Redo to Here icons, or Highlight the 

commands by clicking on the command names. Use Shift-Click to select contiguous 

groups, and CTRL-Click to pick and choose non-contiguous groups.  When all the 

commands are selected, click the Undo or Redo Selected icon.
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■ To Create a Quick Script: Highlight the commands you want to include and click the 

Save Quick Script icon. Paint Shop Pro will create a temporary script that will be 

remembered until a new one is created, the History is cleared, or Paint Shop Pro is closed.

■ To Run a Quick Script: Click the Run Quick Script icon

■ To Convert a Quick Script to a more “durable” script that will remain available in 

future Paint Shop Pro work sessions: On the Script toolbar, open the drop down list of 

scripts and locate the one named “Quick Script Temp.” Click the Edit Selected Script icon.

When the dialog box opens, name the script and click the Save or Save As buttons in the 

lower left corner.

OK, that’s enough overview.  Let’s try these new features out! Once you actually see it in action, the

History Palette will seem a lot less like an unfamiliar new feature and a lot more like a fascinating new

friend.  In fact – it could start feeling like your very own creative design partner.
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By JP Kabala

We’ve all had it happen. You’re working on an image, and everything is going
along perfectly until you hit a snag. The consequences of a decision made 8
or 10 steps ago have come home to roost, and there’s no way to fix the 
problem without undoing that step. You slap yourself on the forehead and say,
“Gee, I really wish I hadn’t done THAT!” or “I should have done that step after
this one.”
Until now, your options were limited.  You could use the Command History to
undo all of the steps taken since the mistake and then try to re-create the 
correct ones that got lost in the process, or you could try to work around the
problem as best you can.
With Paint Shop Pro 9’s new selective undo you can change only the 
commands you need to, without having to disturb the things that are working.

Let’s do an exercise to help you become familiar with the mechanics of 
selective undo.

Selective Undo – 
the Hottest News about 
the History Palette 

What you’ll need:
� Paint Shop™ Pro® 9  

When you complete this tutorial, 
you’ll be able to:
� Create a Sample Image
� Undo Commands
� Redo Commands
� Selectively Undo Commands
� Selectively Redo Commands

www.jasc.com
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Create a Sample Image

1. Create a new image, 640 x 480 with a white raster background.

2. Before we can undo we need to do some things. Perform the following sequence:

■ Choose Effects > Artistic Effects > Balls and Bubbles. When the dialog opens, choose 

the Small Reflections preset and click OK

■ Choose Effects > Texture Effects > Tiles. When the dialog opens, choose the Default pre

set and click OK

■ Choose Adjust > Hue and Saturation > Colorize. When the dialog opens, set the Hue to 

222, the Saturation to 88, and click OK

■ Choose Adjust > Blur > Radial Blur. When the dialog box, choose the Default preset and 

click OK

■ Choose Effects > Art Media Effects > Black Pencil. When the dialog box, choose the 

Default preset and click OK

This sequence mostly produces a messy-looking line drawing, but each of the actions has an 

identifiable effect on the pixels in the image, so you should be able to see what happens when 

that particular step is Undone.

A Simple Undo

3. If your History Palette is not visible, press F3 to make it visible now. 
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4. On the History Palette click the eye icon to the left 

of the Black Pencil entry. 

Two things should happen:

■ The Black Pencil effect should be undone

■ The eye icon now has a yellow X through it.

5. Click the eye icon to the left of the Black Pencil entry again and the yellow X vanishes and the 

Black Pencil effect is redone. 

This is the most basic undo/redo operation of the History palette, and produces the exact same 

result as keying CTRL+Z/ Ctrl+Alt+Z or using the Undo/Redo icons on the Standard toolbar. It’s 

not very exciting, and the only reason we stepped through it here was to be able to compare 

that action with the ones to follow.

Undo to Here

6. Now, in the History Palette, click the name of the Tiles entry and then click the first icon on the 

left side of the History Palette toolbar, called Undo to Here. Three things should happen:

■ The Black Pencil, Radial Blur, Colorize, and Tiles actions should all be undone

■ The eye icon beside each one now has a yellow X through it

■ The image should look like galvanized metal balls on a white background
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Redo to Here

7. Now, on the History Palette, click the name of the Colorize entry and then click the second icon

on the left side of the History palette toolbar, called Redo to Here.  Three things should happen.

■ The Colorize and Tiles actions are redone

■ The yellow X beside each of these actions is now gone

■ The image should look like a purplish mosaic ball on a faintly pink background. 

Undo to Here and Redo to Here each behave in much the same manner as similar commands in

the old Paint Shop Pro Command History did. All commands above them in the list are undone 

or redone. While this is not new behavior for Paint Shop Pro, having easy to understand and 

recognize indicators in the History Palette about exactly which commands have been undone 

(the yellow X’s) helps prevent confusion.

Undo a Non-sequential Command

8. On the History Palette, click the yellow X’ed eye icons beside the Black Pencil and Radial Blur 

entries, so that the yellow Xs vanish and the image appears once again to be the black and 

white line drawing created in Step 2. All yellow X’s should be gone, and each line should be 

preceded by a regular eye icon.
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9. Click the Radial Blur entry to highlight it, and then click the third icon on the left side of the 

History Palette toolbar, called Undo Selected. Three things should happen.

■ The Radial Blur adjustment should be undone

■ The eye icon now has a red X through it

■ The image should appear to be a sharp black and white line drawing of a tiled mosaic, 

rather than the spiraling concentric circles of the blurred image

10. To Redo the Radial Blur effect, highlight the name on the History Palette, then click the fourth 

icon on the left side of the History palette toolbar, called Redo Selected. The image will return 

to its previous state and the red X through the eye icon will vanish.

This is brand new and rather revolutionary behavior. The ability to undo non-sequential 

commands and actions is unique to Paint Shop Pro 9.

Try Steps 9 and 10 with each of the commands on the History Palette and observe the results. 

You may not notice much difference when you selectively undo the Colorize, because the later 

application of Black Pencil strips the color from the image.

This is exciting technology-- but it is not foolproof. Look in the Paint Shop Pro 9 help files for the

topic “Undoing and Redoing History Palette Actions” for some additional information on this 

topic.
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BONUS TIPS: 
Did you know that you can now copy a series of commands-- with all their settings-- from one image to

another? Or to all images currently open in the workspace?

Applying Selected Commands to All Open
Images

1. Select the desired commands from your list in the History Palette— Shift-click to select adjacent

commands, or Ctrl-click to select non-adjacent commands.

2. Right-click on any selected command to display the History Palette's context menu, and 

3. Choose Apply to other open documents. This will apply the commands to ALL open 

documents.

Dragging Commands to One Other Open
Image 
To quickly apply one or more selected commands to another open image, drag the command name(s)

(not the icon) onto another open image.

Next Steps:
Once you learn how to create your own picture frames,

you can use the Preset Shapes Tools and Picture

Tubes to design frames that suit every occasion you

can dream up!


