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Introduction

Welcome!

Contents

This guide is intended to support you, the administrator, in deploying
WordPerfect Office X8 to your network.

Stage 1: Preparing for deployment
Stage 2: Copying the DVD or extracting the ESD to the server.6

Stage 3: Installing the software . . ...................... 8

Stage 4: Maintaining the installations . ................. 19

Appendix: Specialized deployment scenarios. . ........... 26

Deploying Paradox. . ... ... ... 37

Conventions Please note the following conventions used in this guide.

Wherever you see this You'll find

italicized text A placeholder for user-specified
information, such as a path or
filename

bold monospace text A reference to programming
syntax

For more information The following resources offer additional support.

For information on See the following resource

deploying Corel® software: Corel Windows’s Guide to

concepts & processes, Network Deployment

general advice & best practices

Corel Corporation, or a specific ~ Corel® website:

Corel software product www.corel.com

support for Corel software Corel® Support Services
website:
www.corel.com/support

the Microsoft® Windows® Microsoft® website

Installer (MSI) technology,

which is used to install Corel

software
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Stage 1: Preparing for deployment

Highlights:
Server requirements. . . . . . 2
Workstation requirements .3

In this stage

Before beginning the deployment, take the time to familiarize yourself
with your network and the software you want to deploy to it. Doing so
can help your administrative duties run as smoothly as possible.

Getting to know your network. . .. ... ... L 2
Getting to know the software . . ....................... 2
Setting up your network accordingly . . .................. 3

Getting to know your network

Administrative factors

Server factors
Workstation factors

User factors

Make sure to consider your network requirements for the deployment.

Does your organization (or do you, as administrator) have any
particular requirements for deploying and maintaining software?

Does your server have any special characteristics or constraints?
Do your workstations have any special characteristics or constraints?

Do your workstation users have any special workflows?

Getting to know the software

Server requirements

Make sure that your server and workstations are eligible for the
software. If your organization uses a document-management system
(DMS), make sure that it is supported by the software.

You can copy or extract WordPerfect Office X8 to a server that meets
the following requirements:

* Operating system with the latest service pack and critical updates:
Windows Server® 2012 R2, Windows Server 2012, Windows Server
2008 R2

* 1.5 GB of server space (for a typical installation without extra
content)

Remote Desktop Services are supported on the server operating
systems listed above.

For details on server permissions, see “Server setup” on page 3.

To function properly, Corel ScreenCap requires Windows
Media Player.
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Workstation requirements

DMS requirements

For more information

You can install WordPerfect Office X8 on workstations that meet the
following minimum system requirements:

* Windows® 10, Windows 8.1, Windows 7 (32-bit or 64-bit version)
with latest updates and service packs

* 1 GHz or faster (x86) or AMD64 processor
* 1 GB of RAM (x86); 2 GB of RAM (AMD64)

* 1.5 GB of hard-disk space for minimum installation (Paradox, if
included, requires an additional 215 MB of hard-disk space.)

* Mouse or tablet

* 1024 x 768 monitor resolution

« DVD drive (required for box installation)
* Microsoft® Internet Explorer® 11 or later

Some features also require Microsoft® Outlook®.

For details on workstation permissions, see “Workstation setup” on
page 4.

WordPerfect Office X8 offers support for the WordPerfect® Office
(WPD, WPT, WP, QPW) formats on the following document-
management systems:

e Microsoft® SharePoint® Server 2013

¢ Microsoft SharePoint Server 2010

e Microsoft SharePoint Server 2007 with SP1
e SharePoint Portal Server 2003

For details on SharePoint setup, see page 4.

For important notes on installing and using the software, it’s a good
idea to review the Readme file for the software.

To access the Readme file on the installation disc
* Run the following command line (where X: is the disc drive):

X:\ReadMe.htm

Setting up your network accordingly

Server setup

After familiarizing yourself with your network and the software you
want to deploy to it, you can set up your network accordingly.

Do the following:

* Make sure that you are either a local administrator or an
administrator for the domains and workgroups that you are
managing.
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Workstation setup

SharePoint setup

* Create a shared network location for the media you are copying or
extracting to the server, and make sure that you have read/write
access to that location.

If you want to make extra content (such as clipart and videos) available
to workstation users, do the following:

* Set up a shared network location, and make sure that users have
access to that location.

» Use the program DVD to install or copy the content to the shared
location.

Do the following:

* Make sure that you are — and anyone else who will be installing the
software is — either a local administrator or an administrator for the
domains and workgroups that you are managing.

* Make sure that you have — and anyone else who will be installing
the software has — read access to the location where you copied or
extracted media.

WordPerfect Office [Filter is installed automatically when you install
WordPerfect Office X8. If you want WordPerfect Office IFilter as a
standalone application, you can download it from here. To speed
searches, install WordPerfect Office IFilter on all servers that will be
hosting WordPerfect files. Detailed instructions on installing
WordPerfect Office IFilter on Microsoft SharePoint 2013, Microsoft
SharePoint 2010, and Microsoft SharePoint 2007 servers are available
on officecommunity.com.

Step 1: Check your security settings

WordPerfect supports the SharePoint features for Windows Security.
Be sure to configure the local domain to allow password authentication
for your SharePoint server, which requires Hypertext Transfer Protocol
over Secure Socket Layer (HTTPS/SSL) security.

Step 2: Install WordPerfect Office IFilter & SharePoint
Resources

On your SharePoint server, run the appropriate WordPerfect Office
IFilter executable file, which you can download from here. The setup
installs the WordPerfect Office IFilter (for detecting and indexing
stored WordPerfect documents), along with various other
enhancements. Detailed installation instructions are available on
officecommunity.com.

Step 3: Deploy SharePoint support

Workstations automatically receive SharePoint integration (and the
WordPerfect Office IFilter) when WordPerfect Office X8 is installed.
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If desired, you can deploy the following customized settings:

« disabling of WordPerfect toggle for displaying files in Internet
Explorer: Use the WPDVIEWLOCK public property (see page 17).

» home page for the Open File dialog box:
Use the HomePageURL registry key (see page 33).

To extend the SharePoint functions of WordPerfect — for example, to
automate multiple check-ins, multiple check-outs, or file-comparison
reports — you can use PerfectScript™ macros. The following
commands (fully detailed in the installed Macro Help file, psh.chm)
will be of interest.

To do the following Use the following commands

Directly access the document- DocMgmtCheckin

management engine directly, DocMgmtCheckout

bypassing its UI DocSetWorkingFolder
DocMgmtUndoCheckout

Access the document- DocMgmtCheckinDIlg

management Ul DocMgmtCheckoutDlg
DocMgmtDocHistoryDIg

DocMgmtDocPropertiesDIg
DocMgmtUndoCheckoutDlg
DocMgmtVersionCompareDIg

Specify command arguments DocMgmtGetResultCode
(macro-specific values) DocMgmtGetResultDesc
DocMgmtSetArg

Specify document properties DocPropertyGetCount
DocPropertyGetName
DocPropertyGetType
DocPropertyGetValue
DocPropertyRemove
DocPropertyRemoveAll
DocPropertySet

WordPerfect Deployment Guide
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Stage 2: Copying the DVD or extracting the
ESD to the server

After preparing for deployment, you’re ready to copy (DVD) or extract
(ESD) media to the server.

You can modify certain aspects of the media you copied or extracted to
the server or its setup. If you want to support multiple installation
types, you can create multiple versions of the media you copied or
extracted to the server.

Finalizing media on the server

|
Applying patches

Supporting OOXML

Configuring BDE

This section describes recommended steps to take before deploying
from the media copied to the server.

Optionally, you can finalize the media you copied or extracted to the
server in the following ways:
» Customize the registry settings you want to deploy (see page 32).

To avoid deploying the software twice, you may want to check for
software updates and apply them as necessary. For details, see page 21.

You can deploy support for saving to Office Open XML (OOXML)
format from within WordPerfect Office X8.

To deploy support for saving to OOXML

1 After copying the DVD or extracting the ESD content to the server,
open the <Language> folder.

2 Create a new folder, and name it MSPack.

3 In your browser, navigate to http://apps.corel.com/redirect/

command.asp?_redirect=command&function=download&app=CH
O&subfunction=ffc&lang=en and download the Microsoft Office

Compatibility Pack.

4 Save FileFormatConverters.exe to the MSPack folder.

All future workstation installations from this location will
automatically allow users to save to the Microsoft 2007-2016 format.

For WordPerfect and Quattro Pro® to function properly, you must
ensure that the network folder settings for the Borland® Database
Engine (BDE) point to a folder for which all users have write and
delete permissions.
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Testing

To adjust the Borland Database Engine

1

2
3
4

[9)]

Log on to the server console as an administrator.
From the Windows Control Panel, open the BDE Administrator.
Click the Configuration tab.

Expand the Configuration tree, and navigate to the following:
Drivers\Native\PARADOX

In the right pane, click the field to the right of the NET DIR entry.

Click ..., and browse to the location of the desired network folder.
All users must have write and delete permissions for this folder.
Click Object » Apply.

Click OK to confirm the save, and then click OK again when you
are prompted to restart all Borland Database Engine applications.

You may want to test on a small subset of workstations before rolling it
out to your entire organization.
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Stage 3: Installing the software

Highlights:
Using switches. . ....... 10
Using public properties . .12

In this stage

After copying the contents of the DVD or extracting the ESD to the

server, you can use it to install the software on the workstations in one

of two ways:

» manually, by having users “pull” the software to their own
workstations

 automatically, by “pushing” the software to the workstations on their
users’ behalf

Pulling thesoftware. ......... ... ... ... ... .. .. ... .... 8
Pushing thesoftware.......... ... .. ... ... ... ........ 9

Pulling the software

In this section

If users have both access to the server and administrator-level rights to
their workstations, they can install (or “pull”) the software themselves.
To do this, they run the setup from the media you copied or extracted to
the server.

Preparing for pull installation. . . ....................... 8
Carrying out a pull installation. . .. ........ ... ... ... .... 9

Preparing for pull installation

Requirements

Recommendations

To ensure that the pull-installation process runs as smoothly as
possible, take the time to prepare for it.

Confirm that each workstation meets the minimum requirements for
the software (see “Workstation requirements” on page 3).

* Confirm that each workstation user has read-only access to the media
you copied or extracted to the server and administrator-level access
to the workstation (see also “Workstation setup” on page 4).

Map the workstations to the media you copied or extracted to the
server, and set the workstations to log in to that server location at
startup. Doing so ensures that users are always connected this
content.

» Confirm that all workstations are running the latest version of
Microsoft Windows Installer. Doing so simplifies the installation
process.
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Carrying out a pull installation

Users pull the software to their workstations by running the setup from
the media you copied or extracted to the server.

The degree of user interaction required by the setup depends on how
you’ve customized the media you copied or extracted to the server and
the deployment process.

If you prefer to restrict user customization, you may want to offer
multiple versions of the media you copied or extracted to the server —
one per set of installation options.

To pull the software to a workstation

1 Browse to the location of the media you copied or extracted to the
server, and double-click Setup.exe.

2 Carry out the installation, specifying any desired options, by
following the on-screen instructions.

For best results, limit the installation path to 70 characters.

Pushing the software

In this section

To “push” the software from the media you copied or extracted to the
server to the workstations, you must write a command line that includes
the following:

+ the filename of the setup you want to use
* any desired switches, to control how the setup runs
+ any desired public properties, to specify installation settings

Using this command line, you can install the software on the
workstations by using any supported push method.

Specifying the setup file. . . ... ... ... .. L 9
Using switches . . . ... 10
Using public properties . ........ ... ... .. . . . ... 12
Running your commandline ......................... 17

Specifying the setup file

The most important item to specify in your command line is the
executable file for the setup: the Setup.exe file on the server you want
to use:

\\server\path\Setup.exe
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& If your path contains spaces, you must place quotation marks around it:

"\\server\path containing spaces\Setup.exe"

If your network requires deployment via msiexec.exe instead of
Setup.exe, see page 35.

Using switches

By using switches in your command line, you can control the setup
process. Listed in this section are the switches most commonly used
when installing the software.

For a list of all command-line switches for Microsoft Windows
Installer, please see the Microsoft website.

/I Event logging

Use /1 to log installation events.

Parameter What it logs

i Status messages

w Nonfatal warnings

e All error messages

a Initiated actions

r Action-specific records

u User requests

m Error messages for out-of-memory warnings or fatal
exits

o} Error messages for insufficient hard-disk space during

server installation

p Terminal properties

All of the above, in a single log file
NOTE: Alternatively to /1*, you can use /log.

\% Very detailed information

The default parameters for /1 are iwearmo (/liwearmo "c:\install
Logs.txt").

If you want to specify a path for the log file, use the following syntax:
/1 "path”

"'l If you do not specify a path and filename, the log file is created in the
current user’s temporary (Temp) folder.

WordPerfect Deployment Guide
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/q

?

In the following example, the /1 switch (with default parameters) is
used to log installation events in the specified file:

\\server\path\Setup.exe /1 "C:\install._txt"

Limited setup Ul
Use /q to limit the amount of setup Ul encountered during installation.

You can use /q to prevent users from entering their own registration
information, to help enforce specific installation options, or even to
perform silent installations (in which no setup Ul is visible
whatsoever).

Parameter  What the user sees during installation

n No UI whatsoever. Errors are logged in a file that you
can control by using /1 (see page 10). This is the
default parameter.

NOTE: Alternatively to /qn, you can use /quiet.

b Basic Ul a progress bar and a Cancel button. If the
user pushes the Cancel button, the installation is
rolled back upon confirmation.

NOTE: Alternatively to /gb, you can use /passive.

o] Basic Ul: only a progress bar. The user cannot cancel
the installation.

b+ Basic Ul: a progress bar and a Cancel button. If the
user pushes the Cancel button, the installation is
rolled back (without first prompting for confirmation).

r Reduced Ul: A progress bar, along with a page
containing information about the installation. The user
can cancel the installation.

f Full UI

The default parameter for /q is n.

In the following example, all setup Ul is suppressed, and any errors are
recorded in the specified log file:

\\server\path\Setup.exe /q /1 "C:\Logs\My_Log.txt"

Help
The /7 switch (or Zhelp) displays Help for the setup.

WordPerfect
OFFICE

Deployment Guide
Stage 3: Installing the software 11



Using public properties

ADDLOCAL

ASSOCIATE_DOC_FILES

ASSOCIATE_PPT_FILES

ASSOCIATE_XLS_FILES

DESKTOPSHORTCUTS

By using public properties in your command line, you can specify
installation settings. Listed alphabetically in this section are the
properties most commonly used during software installation.

For a list of all command-line properties for Microsoft Windows
Installer, please see the Microsoft website.

Installing specific components

For details on this scenario, see the following topics in the appendix:
“Deploying specific features” on page 26

Associate DOC files with WordPerfect

You can associate all Microsoft® Word (DOC and DOCX) files with
WordPerfect by using the following property:

ASSOCIATE_DOC_FILES=1

Associate PPT files with Presentations

You can associate all Microsoft® PowerPoint® (PPT and PPTX) files
with Presentations by using the following property:

ASSOCIATE_PPT_FILES=1

Associate XLS files with Quattro Pro

You can associate all Microsoft® Excel® (XLS and XLSX) files with
QuattroPro by using the following property:

ASSOCIATE_XLS_FILES=1

Opting out of desktop shortcuts

You can prevent the installation of desktop shortcuts by using the
following property:

DESKTOPSHORTCUTS=0
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FORCENOSHOWLIC Suppressing the EULA prompt

&

INSTALL_APP

INSTALLDIR

&

If the software is installed silently (see page 11), each workstation user
will be prompted to accept the End-User License Agreement (EULA)
at first start-up. To suppress the EULA prompt on the workstations, use
the following property:

FORCENOSHOWL1C=1

If you choose to suppress the EULA prompt on the workstations, you
are accepting the terms of the EULA on behalf of your organization and
all users. Deployed installations will not prompt users to review the
license agreement.

Installing only specified programs

By default, WordPerfect Office X8 installs WordPerfect, Quattro Pro,
and Presentations™. To install only one (or two) of these programs, use
the INSTALL_APP property with one of the following values (or two
comma-separated values).

Value What it installs

presentations Presentations

quattropro Quattro Pro

wordperfect WordPerfect

In the following example, only WordPerfect is installed:
Setup.exe INSTALL_APP=wordperfect

In the following example, only WordPerfect and Quattro Pro are
installed:

Setup.exe INSTALL_APP=wordperfect,quattropro

You can also install specific program features. For details, see page 26.

Customizing the installation path

When deploying from the media you copied or extracted to the server,
use the following public property to customize the installation path of
the software:

INSTALLDIR=""C:\Directory one\Directory two"

For best results, do not end the path with a backslash ( \).
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INSTALL_IFILTER

MIGRATE_PRODUCT

REBOOT

SERIAL NUMBER

Managing IFilter installation

You can prevent the installation of the WordPerfect Office IFilter by
using the following property:

INSTALL_IFILTER=0

Migrating user settings during upgrade

When upgrading from a previous version of WordPerfect Office, you
can use the MIGRATE_PRODUCT property to migrate user settings. For
details on upgrading to WordPerfect Office X8, see page 15.

Handling reboots

The REBOOT property is used with one of the following values to
specify how the installation process handles any required reboots.

Value What it does

Force Prompts for reboot after installation. If the

(or F) setup Ul is suppressed, the computer is
automatically rebooted after installation.
NOTE: Alternatively to REBOOT=Force,
you can use the /forcerestart switch.

Suppress Prompts for reboot during installation (if

(orS) required), but reboots automatically after

installation. If the setup Ul is suppressed, all
required reboots are automatic.

NOTE: Alternatively to
REBOOT=Suppress, you can use the /
promptrestart switch.

Real lySuppress
(or R)

Suppresses all reboots and all reboot
prompts, both during and after installation.
NOTE: Alternatively to

REBOOT=Real lySuppress, you can use the
/norestart switch.

Inputting your serial number

To input your assigned serial number, use the following property:
SERIALNUMBER=serial number

You must type the serial number without any spaces.
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SPLITTABLEROWS

|fv/
45

UPGRADE_PRODUCT
and
UPGRADE_PRODUCT _
DEFAULT

Splitting table rows

By default, WordPerfect disables the setting for splitting table rows
across pages (Table » Format » Row P Divide row across pages) —
in part, to ensure that footnotes can be added within tables. To enable
this setting on the workstations, use the following property:

SPLITTABLEROWS=1
Enabling this setting corresponds to writing the registry key
WPTablesSpanRows, while disabling it corresponds to writing

WPTablesSpanRows_defaultOff. See page 32 for details on registry
keys.

Upgrading to WordPerfect Office X8

To upgrade to WordPerfect Office X8 and migrate user settings from a
previous version of WordPerfect Office, you must use several public
properties together.

First, you must use the following property to specify which version (or
versions) of WordPerfect Office to search for:
UPGRADE_PRODUCT=value

The UPGRADE_PRODUCT property is used with one (or more) of the
following (comma-separated) values:

Value What it searches for

All Any installed version of WordPerfect Office
17 WordPerfect Office X7

16 WordPerfect Office X6

15 WordPerfect Office X5

14 WordPerfect Office X4

13 WordPerfect Office X3

12 WordPerfect Office 12

11 WordPerfect Office 11

NOTE: You cannot upgrade from
WordPerfect Office 11 Professional without first
uninstalling Paradox® (if included).

None Nothing — upgrade feature is disabled

Next, you must use the following public property to specify whether to
upgrade the previous version (or versions) of WordPerfect Office
found:

UPGRADE_PRODUCT_DEFAULT=value
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The UPGRADE_PRODUCT_DEFAULT property is used with one of the
following values:

Value What it does

On Automatically upgrades all installed versions
(or any other value) of WordPerfect Office

Off Does not automatically upgrade any installed
version of WordPerfect Office

To upgrade to WordPerfect Office X8, you must use
& UPGRADE_PRODUCT and UPGRADE_PRODUCT_DEFAULT together.
Using only one property causes it to be ignored altogether.

Finally, you can use the following public property to migrate user
settings from a previous version of WordPerfect Office:

MIGRATE_PRODUCT=value

The MIGRATE_PRODUCT property is used with one of the following
values:

Value Where it migrates settings from

Latest  The latest installed version of WordPerfect Office

Any WordPerfect Office X7

16 WordPerfect Office X6

15 WordPerfect Office X5

14 WordPerfect Office X4

13 WordPerfect Office X3

12 WordPerfect Office 12

11 WordPerfect Office 11

None Nowhere — the migration feature is disabled

In the following example, all installed versions of WordPerfect Office
are automatically upgraded to WordPerfect Office X8, and user settings
are migrated from the latest installed version of WordPerfect Office:

UPGRADE_PRODUCT=A11 UPGRADE_PRODUCT_DEFAULT=0n
MIGRATE_PRODUCT=Latest

WordPerfect Deployment Guide
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WPDVIEWLOCK

|fv/
45

In the following example, only WordPerfect Office 12 and
WordPerfect Office X3 are searched for — but they are not
automatically upgraded to WordPerfect Office X8; in addition, user
settings are migrated from WordPerfect Office 12:

UPGRADE_PRODUCT=12,13 UPGRADE_PRODUCT_DEFAULT=0FF
MIGRATE_PRODUCT=12

Locking the display of WPD files in Internet Explorer

By default, users have access to the following WordPerfect setting:
Tools P Settings P Files » Allow Internet Explorer to display WPD
files. To make this setting unavailable, use the following property:

WPDVIEWLOCK=1

Making this setting unavailable corresponds to writing the registry key
WPWinViewerLocked. For details on registry keys, see page 32.

Running your command line

SCCM

SMS

Your command line can be used to push the software to the
workstations through any of the following:

¢ a batch file — see the Microsoft website for details
* a GPO — see the Group Policy SDK for details

* a third-party push technology — see the manufacturer’s
documentation for details

For many administrators, using a third-party push technology is the
preferred push method. This section offers general guidelines on using
a few such technologies.

At the time of this writing, Corel has verified support for Microsoft®
System Center Configuration Manager (SCCM) only insofar as its
Microsoft Systems Management Server (SMS) components.

For complete information on using SCCM, please see the Microsoft
website.

For deployment to the workstations on a “per-system” basis using
package definition files (or “packages”), WordPerfect Office X8
supports the use of Microsoft Systems Management Server (SMS).

You can create a package from scratch — or you can create one from
the existing SMS file included with WordPerfect Office X8 (in the
Administrator folder on the installation disc or the media you copied
or extracted to the server).

For complete information on using SMS files, please refer to your
resource kit for Microsoft Systems Management Server.
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&

The recommendations posted on the Microsoft website have not been
tested with WordPerfect Office X8 and must therefore be used at your
discretion.
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Stage 4: Maintaining the installations

In this stage

An important part of administering a network is maintaining the
software installed on its workstations.

Repairing the software. . .......... ... ... ... ... ... ... 19
Modifying thesoftware . . . ...... ... ... ... ... ........ 21
Updating the software. . . ......... ... ... .. .. ........ 21
Removing the software . .......... ... ... .. ... ....... 23
Troubleshooting the software . ....................... 25

Repairing the software

Repairing the software lets you install (or reinstall) missing (or
corrupted) components. You can repair a single installation of the
software by using the Windows Control Panel on that workstation, or
you can repair multiple workstation installations by using a command
line.

Repairing a single installation

You can use the Windows Control Panel to repair a single installation.

To repair an installation with the Windows Control Panel

1 In the Windows Control Panel, display the list of currently installed
programs, and choose the program from the list.

2 Click Uninstall/Change (for Windows 8.1, Windows 8, or Windows
7).

3 Enable the Repair option, and then click Repair.

4 Follow the on-screen instructions.

Repairing multiple installations

You can use a command line to repair multiple installations at a time.

/f Basic repair

Use the 7/ switch with the Setup.exe file from the media you copied or
extracted to the server:

\\server\path\Setup.exe /Ff
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&

REINSTALL
and REINSTALLMODE

You cannot use the /F switch with public properties. For greater
control over the repair process, use the REINSTALL and
REINSTALLMODE properties instead of /F.

The /¥ switch has the following parameters.

Parameter What it does

p Reinstalls missing files

o} Reinstalls missing files and files older than current
version

e Reinstalls missing files and files equal to or older than
current version

d Reinstalls missing files and files different from current
version

a Reinstalls all files

u Reinstalls all required user-specific registry keys:
HKEY_ CURRENT _USER, HKEY_ USERS

m Reinstalls all required computer-specific registry keys:
HKEY_LOCAL_MACHINE,
HKEY_CLASSES_ROOT

s Reinstalls all existing shortcuts

v Runs from the source files and re-caches the local

package

The default parameters for /F are oums.

Advanced repair

For greater control over how the software is repaired, use the
REINSTALL and REINSTALLMODE public properties together.

Property

What it does

REINSTALL=ALL Reinstalls all program features. If you

prefer to reinstall only specific features
(see page 26 for a list), use the
following syntax:
REINSTALL=Feature

REINSTALLMODE=type Specifies the type of reinstallation to

perform. The values for this property
are the same as the parameters for the /
f switch, so its default values are oums.
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Modifying the software

Modifying the software lets you change which program features are
installed. You can modify a single installation of the software by using
the Windows Control Panel on that workstation, or you can modify
multiple workstation installations by using a command line.

Modifying a single installation

You can use the Windows Control Panel to modify a single installation.

To modify an installation with the Windows Control Panel

1 In the Windows Control Panel, display the list of currently installed
programs, and choose the program from the list.

2 Click Uninstall/Change (for Windows 8.1, Windows 8, or Windows
7)

3 Enable the Modify option, and then click Next.

4 Follow the instructions that appear.

Modifying multiple installations

REINSTALL
and REINSTALLMODE

REMOVE

You can use a command line to modify multiple installations at a time.

Adding features

You can use the REINSTALL and REINSTALLMODE properties to add
program features. For details on these properties, see page 20.
Removing features

You can use the REMOVE public property to remove a program feature:
REMOVE=Feature

For more than one feature, use a comma-separated list:

REMOVE=Featurel,Feature2

For a list of available features, see page 26.

Updating the software

Corel periodically releases Microsoft patch (MSP) files — or
“patches” — for its products. Installing patches helps keep the
software up-to-date.
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Applying patches

Patching

If you want to centrally maintain updates, WordPerfect Office must be
installed using a corporate serial number and specify
ALLOW_PRODUCTUPDATES=0.

In this guide, Patch. exe is a placeholder for the filename of the patch.
The actual filename varies with each patch.

Many network administrators keep their software up-to-date by
monitoring the Corel Support Services website (www.corel.com/
support). When a patch is made available, these administrators
download it and carry out the patching process themselves.

In this guide, \\server\path\Patch.exe is a placeholder for the
location and filename of the downloaded patch.

After locating and downloading a patch, you can apply it to the media
you copied or extracted to the server and then use the updated media to
patch the installed software.

You can apply a patch to the media you copied or extracted to the
server. Optionally, you can begin by extracting the patch files to a
specified location.

To extract the patch files to a specified location

To extract the patch files to a specified location (instead of the default
Temp folder), use the following command-line syntax:

\\server\path\Patch.exe /extract_all "location"

Be sure to apply all extracted patch files to the media you copied or
extracted to the server. Applying only some of the patch files may
cause the installations to function incorrectly.

To apply the patch files

Use a command line that includes the executable file for the patch and
the /a switch:

\\server\path\Patch.exe /a

If necessary, you can include the location of the media you copied or
extracted to the server:

\\server\path\Patch.exe /a
"\\server\path\Setup.exe"
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|fv/
45

After patching the media you copied or extracted to the server, you can

deploy the update to the workstations.

To patch the workstations

Use the following command-line syntax:
\\server\path\Setup.exe REINSTALL=ALL

By default, the REINSTALLMODE=0oums property is applied. For best
results, you may want to specify REINSTALLMODE=vdm:

\\server\path\Setup.exe REINSTALL=ALL
REINSTALLMODE=vdm

For details on REINSTALL (and REINSTALLMODE), see page 20.

To silently patch the workstations

Use the following command line:

\\server\path\Patch.exe /s

For best results, avoid silently patching the workstations.

Removing the software

Removal of media from the
server

&

Workstation removal

You can remove the software from your network. Uninstalling the
software cleanly is crucial when the time comes to upgrade to a newer
version.

You cannot automate the removal of media you copied or extracted to
the server. Instead, you must manually delete it from the server.

For best results with deleting, begin by doing the following:
» Make sure that the programs to be removed — and their associated
files — are not currently in use on the workstations.

* Ifyou are using Windows Terminal Server, make sure that all users
are logged off.

The only way to re-cover a deleted media is to re-create it by re-
running the setup.

You can remove a single installation of the software by using the
Windows Control Panel on that workstation, or you can remove
multiple workstation installations by using a command line.
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Removing a single installation

Windows 10 or Windows 8.1

Windows 7

You can use the Windows Control Panel to remove a single installation.

To remove an installation with the Windows Control Panel

1 With a mouse, move your pointer into the upper-right or lower-right
corner, and then move it up or down to click Search.

2 Type Control Panel in the search box, and press Enter.
3 Click Uninstall a program under Programs.

4 Double-click WordPerfect Office X8 on the Uninstall or change a
program page.
5 Follow the uninstallation instructions in the setup.

If you want to remove user files (such as presets, user-created fills,
and customized files), enable the Remove user files check box.

1 On the Windows taskbar, click Start » Control Panel.

2 Click Uninstall a program under Programs.

3 Double-click WordPerfect Office X8 on the Uninstall or change a
program page.

4 Follow the uninstallation instructions in the setup.

If you want to remove user files (such as presets, user-created fills,
and customized files), enable the Remove user files check box.

Removing multiple installations

/X

REMOVE
and REMOVEUSERFILES

You can use a command line to remove multiple installations at a time.

If you want to remove user files (such as presets, user-created fills, and
customized files), enable the Remove user files check box.

Basic removal

You can use the /x switch (or the Zuninstall switch) to silently
remove the software:

\\server\path\Setup.exe /x

Advanced removal

If you want more control over the removal process, use the following
two public properties.

Property What it does

REMOVE=ALL Removes all features
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Property What it does

REMOVEUSERFILES=value  Specifies whether to remove user

files:
* 0O—no
e 1—yes

Troubleshooting the software

For help troubleshooting any issues with the software, please visit the

Corel® Knowledge Base™ (www.corel.com/knowledgebase), an
online repository of FAQs and articles.
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Appendix: Specialized deployment scenarios

In this appendix

If you require a more specialized deployment scenario, the
supplementary topics in this appendix may be of interest to you.

Deploying specific features. . . . .......... ... ... ... . ... 26
Deploying macros and templates. . .................... 27
Working with MSTfiles . ......... .. ... .............. 31
Working with registry keys. . . ........ ... L 32
Deploying customized installation settings .............. 34
Deploying the software with msiexec.exe ............... 35

Deploying specific features

When performing a basic or silent installation with the /q switch (see
page 11), you may want to use the ADDLOCAL property to specify
which software features to install. You can specify a single feature:

ADDLOCAL=Feature

Or you can specify a comma-separated list of components:
ADDLOCAL=Featurel,Feature2

You can even specify all features:
ADDLOCAL=ALL
If you want to install nearly all features, naming them individually

would be quite tedious. In this scenario, you can use the REMOVE public
property to specify the features to subtract from ADDLOCAL=ALL:

ADDLOCAL=ALL REMOVE=Featurel,Feature2

& Feature names are case-sensitive.

Specifying software features by feature name

You can specify individual WordPerfect Office X8 components by their
feature name.

Some editions of the software do not include certain features listed in
this section.

Feature names are case-sensitive.

WPO component Feature name

WordPerfect WP
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WPO component Feature name

QuattroPro QP
Presentations PR
WordPerfect® Lightning™ LT
Support for document display in Web WPBrowse
browser

Borland Database Engine 5.2 UtBDE
QuickFinder UtQFind
Conversion Utility UtWPConv
Clipbook utClipbk

Deploying macros and templates

&

Deployment methods

Macros and templates make it easy to customize solutions for your
organization. You can customize a macro that carries out a set of
actions, assign that macro to a shortcut key, and save the macro and its
shortcut key to a template, so that users who work from that template
have access to the macro and its shortcut key.

If you want, you can make customized macros available to workstation
users by storing them in a template. In fact, you can store every macro
in the default template file (wp18$$.wpt, where $$ is the default
writing-tools language), and then deploy that default template file to
each user’s machine.

Template macros are not transferred to documents based on that
template. Consequently, template macros are available only when their
template is available, so it is important to choose a final location for a
template before you put it into active use.

WordPerfect Office X8 supports using a centralized, network-based
repository for storing your macros and templates. However, you can
deploy macros and templates if preferred.

You can deploy macros and templates as you would any other file:

* by running a specialized command line, such as with a push
technology (see page 9)

* by using an MST file (see page 31)

WordPerfect
OFFICE

Deployment Guide
Appendix: Specialized deployment scenarios 27



Installing macros and templates
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Default items

User-created items

Migrating macros and

Macro migration

At any point, users can install macros and templates to their
workstations.

Template macros set as read-only do not run properly.

By default, WordPerfect Office installs macros and templates at the
following location (where X: is the drive where WordPerfect Office is
installed, and where $$ is the installation language):

X:\Program Files\Corel\WordPerfect Office X8\Languages\$$\
Template\Custom ProgramName templates

User-created macros and templates are stored at the following location

(where X: is the drive where the operating system is installed):

¢ Windows 10, Windows 8.1, and Windows 7:
X:\Users\UserName\AppData\Roaming\Corel\PerfectExpert\18\
Language\Custom ProgramName Templates

If a new WordPerfect template doesn’t appear after it is installed to the
PerfectExpert or saved to the Custom WP Templates folder, you must
refresh the PerfectExpert.

To refresh the PerfectExpert

1 In WordPerfect X8, click File » New from project.
2 Click the Create new tab.

3 Click Options, and then click Refresh projects.

If the new template still does not appear, try changing the category
from [WordPerfect] to Custom WP templates.

templates

Macros and templates can be migrated from an earlier version of
WordPerfect.

Most macros from a previous version of WordPerfect can be
recompiled to work in WordPerfect X8.

By default, warnings are not displayed for obsolete tokens because they
do not interfere with the functioning of most macros. You can choose to
display these warnings, however.

If you want to store your organization’s macros in a centralized
repository, you can set WordPerfect to compile and run all macros
locally (that is, from the user’s temporary folder). For details, see “To
specify how WordPerfect runs and compiles macros” in the
WordPerfect Help.
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Template migration

AN

"

7|

To manually migrate a macro

1 Copy the macro to your template folder (if you haven’t already done
S0).

Start WordPerfect X8.

Click Tools » Macro » Edit.

Navigate to the macro, select it, and then click Edit.
Click the end of the first line.

Press the Spacebar, and then press Backspace.

N OO Ul e WN

Click Save & compile.

The macro is recompiled for WordPerfect X8. Be sure to correct any
errors incurred — often, such errors result from updated or removed
commands.

To display warnings for obsolete tokens

1 Click Start » Programs » WordPerfect Office X8 » Utilities »
PerfectScript.

2 In PerfectScript, click Tools » Settings.

3 On the Compile page, enable the Warn when using unsupported
features check box.

4 Click Apply, and then click OK.

Default templates — and most other templates — from previous
versions of WordPerfect can be migrated to WordPerfect X8.

Using a migrated template can prevent WordPerfect X8 from
displaying its new features. For best results, migrate only the desired
template components (toolbars, menus, keystroke assignments, and so
on).

When you open a template, WordPerfect checks whether the template
is missing default menu commands. You can merge missing menu
commands into a template by following the procedure “To merge
default menu commands into a template” in the WordPerfect Help.

To manually migrate template components

1 Do one of the following:

* Copy the source templates to your template folder for
WordPerfect Office X8, and then start WordPerfect X8.

» Start WordPerfect X8. Click Tools » Settings, and then click
Files. On the Template page, use the Additional template folder
box to specify the location of the source templates.

2 Click Tools » Settings, and then click Customize.

3 Click the tab for the template component you want to migrate.
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4 Click Copy, and then do the following:

* From the Template to copy from list box, choose the source
template.

* From the Select toolbars to copy list, select the component to
migrate. Hold down CTRL to select multiple components.

* From the Template to copy to list box, choose the target template.
(If you want, you can choose the default template.)

» Click OK.

You are prompted to rename a component if another component by
that name exists. To distinguish between similar components, you
may want to append version numbers to their names.

5 To apply the new component, enable its check box.

6 To migrate each additional component, repeat steps 3 to 5.

Migrating user settings

QuickWords list

QuickCorrect list

Address Books

In push-installation scenarios, administrators can migrate users’
customized settings automatically (see page 15). In pull-installation
scenarios, users themselves can choose to migrate their settings.

Locate the QuickWords™ list file that belongs to the previous version,

and use it to replace the QuickWords list file for WordPerfect X8. The

QuickWords list file for WordPerfect X8 is saved at the following

location (where X: is the drive where Windows is installed and $$ is the

default writing-tools language).

¢ Windows 8.1, Windows 8, and Windows 7:
X:\Users\UserName\AppData\Roaming\Corel\PerfectExpert\
18\Language\Custom WP Templates\QW18$$.WPT

Locate the QuickCorrect™ list file that belongs to the previous version,

and use it to replace the QuickCorrect list file for WordPerfect X8. The

QuickCorrect list file for WordPerfect X8 is saved at the following

location (where X: is the drive where Windows is installed and $$ is the

default writing-tools language).

¢ Windows 8.1, Windows 8, and Windows 7:
X:\Users\UserName\AppData\Roaming\Corel\WordPerfect
Office X8\Writing Tools\WT18$$.UWL

First, export the Address Books from the previous version of
WordPerfect to an ABX (version 8) or TXT file format. Then, in
WordPerfect X8, create an empty Address Book and import the ABX
or TXT file into it.
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/ Address Book records can contain hard returns. For example, this can

| happen when there are two lines of the street address. If an Address
Book does not properly import from a text file, review the contents of
the file with a text editor, and remove any extraneous hard returns.

"

Working with MST files

If you want to apply a Microsoft transformation (MST) file to the setup,
simply apply it to your command line.

By default, MST files are applied to the Setup.msi file for the setup.

To apply a transformation to the setup

1 Store the MST file in the location where you copied or extracted
media to the server.

2 Use the TRANSFORMS property to specify that MST file, as shown
here (where MST is the filename of the MST file):

Setup.exe TRANSFORMS="MST"

If the MST file is not in the same folder as Setup.exe, MST must specify
& the full path and filename of the MST file.

Applying a transformation to a specific MSI file

To apply an MST file to a specific MSI file, use the following syntax
(where MSI1 is the filename of the MSI file, not including its extension;
and where MST is the filename of the MST file, including its extension):

Setup.exe TRANSFORMS_MSI=""MST"
If the MST file is not in the same folder as the MSI file, MST must
& specify the full path and filename of the MST file.
Example 1 To apply my_wp.mst to WP.msi (in the same folder), use the following
syntax:
Setup.exe TRANSFORMS WP="my wp.mst"
Example 2 To apply MyTransform.mst to ENPExp.msi (in the same folder), use
the following syntax:
Setup.exe TRANSFORMS ENPExp=""MyTransform.mst"

Troubleshooting MST files
If you have trouble applying an MST file, do the following:

WordPerfect Deployment Guide

OFFICE Appendix: Specialized deployment scenarios 31



Check the syntax of your command line — in particular, the path to
the MST file.

* Check your permissions.
* Make sure that the MST file was created correctly.
+ Check the associated MSI files.

For additional help with MST files, contact Corel Support Services
(www.corel.com/support). Please note, however, that charges will

apply.

Working with registry keys

After copying or extracting media to the server, you may want to edit
its registry keys for deployment to the workstations. By doing so, you
can avoid having to manually configure the registry keys of each
individual workstation installation of the software.

Deploying program defaults

&

When a workstation user first starts a WordPerfect Office X8 program,
settings for that program are pushed from
HKEY_LOCAL_MACHINE registry keys to
HKEY_CURRENT_USER keys for that user. If you want to mandate
the default program settings for all workstation users, you can deploy
the HKEY LOCAL_MACHINE registry keys for those settings.

You can use a local installation of WordPerfect Office X8 to determine
which HKEY_LOCAL_MACHINE registry keys are affected by a
specific program setting. Open the program, and specify the setting that
you want to deploy to the workstations. This setting is saved as a value
for a specific registry key at the following location:

HKEY_CURRENT_USER\Software\Corel\ProgramName\18

To deploy this program setting to all workstation users, apply it to the
registry file (or MSI table) for the media you copied or extracted to the
server as a value for the corresponding HKEY_LOCAL_MACHINE
registry key at the following location:

HKEY LOCAL MACHINE\SOFTWARE\Corel\Setup\
WordPerfect Suite\18\Migrate\Software\Corel\ProgramName\18

The method described in this section can be used to deploy almost any
registry key for WordPerfect Office X8. Two common examples
follow.

For best results, do not use this method to deploy file paths.
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Shadow Cursor setting

Open File home page

Migrating installed files to
the user profile

The Shadow Cursor setting for WordPerfect is stored at the following
location for each workstation user:

HKEY_CURRENT_USER\Software\Corel\WordPerfect\18\
Shadow Cursor

To deploy the same Shadow Cursor setting to each user, you must copy
the value of the HKEY_CURRENT _USER registry key for that
setting (""'Shadow Cursor State''=setting) to the following
HKEY_LOCAL_MACHINE registry key for the media you copied
or extracted to the server:

HKEY_ LOCAL_MACHINE\SOFTWARE\Corel\Setup\
WordPerfect Suite\18\Migrate\Software\Corel\
WordPerfect\18\Shadow Cursor

The Web Mode view of the Open file dialog box can be customized to
use a specified folder as its home page. Users can specify this home
page by clicking the Web mode icon in the Open file dialog box,
browsing to the desired folder, and clicking Internet » Set home page.
This home-page setting is stored as a value
("HomePageURL"="URL") of the following registry key for each
user:

HKEY_CURRENT_USER\Software\Corel\PerfectFit\18\
Virtual Namespaces\:Internet

Specify the HomePageURL value for the following registry key for
the for the media you copied or extracted to the server:

HKEY LOCAL_MACHINE\SOFTWARE\Corel\Setup\
WordPerfect Suite\18\Migrate\Software\Corel\
PerfectFit\18\Virtual Namespaces\:Internet

You can deploy a customized default template, QuickWords list, or

QuickCorrect list by creating a registry key at:

* (32-bit version)
HKEY_LOCAL_MACHINE\SOFTWARE\Corel\WordPerfect\
18\EN\FileMigration

* (64-bit version)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\
Corel\WordPerfect\18\EN\FileMigration

In the FileMigration folder, you must create a key for each pair of
source folders and destination folders. When you name them, use a
name that describes the file’s purpose. The following string values must
exist within this registry key:

* SOURCEPATH — the files’ source path

* DESTINATIONPATH — the files’ destination path. You can use
variables such as $APPDATA$ and $PERSONAL$
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When naming, you must follow the following syntax: FILE 01,
FILE 02, FILE 03, and so on. It is important the filenames are
sequential with no breaks in the

Deploying customized installation settings

To modify the settings used to install the software on the workstations,
you can create an XML file and name it Persist.xml.

XML lines must be inside <ICA> </I1CA> and
& <PROPERTIES> </PROPERTIES> tags. Otherwise, the Persist.xml
file is ignored by setup.

Each entry you add to Persist.xml must correspond to a public property
for the software (see page 12). The syntax of each entry should be as
follows:

<Property name="'property' value="value" />

By modifying the value of an existing entry in Persist.xml — or by
adding a new entry — you can customize the installation settings
deployed from the media you copied or extracted to the server. This
deployment method offers an excellent alternative to customizing a
command line.

Example 1 The following Persist.xml entry would specify that automatic software
updates are enabled:

<Property name=""ALLOW_PRODUCTUPDATES" value="1" />

By changing the value of this entry from 1" to "'0"" (and saving this
change to Persist.xml), you can disable automatic updates for the
workstation installations.

Example 2 The following Persist.xml entry would specify the serial number for
the installation:

<Property name="SERIALNUMBER"™ value="'SN" />

By changing the ""SN**value, you can specify a different serial number
for the workstation installations.

Example 3 The following Persist.xml entry would specify that WordPerfect Office
is installed with updates disabled:

<ICA><Properties><Property
name=""ICA_PropertyPresistFile._Created" value="04/
15/16 11:13:59"/><Property name=""SERIALNUMBER"
value="" WP18C22-XXXXXXX-YYYYYYY-Z2Z227777 '/
><Property name="ALLOW_PRODUCTUPDATES" value="0"/
></Properties></1CA>
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Deploying the software with msiexec.exe

Command-line syntax

MST files

Alternatively to using Setup.exe, you can deploy the software by using
msiexec.exe — a Microsoft Windows Installer file provided by the
Windows operating system. In fact, you must use msiexec.exe if you
want to interact directly with the MSI files, such as in the following
scenarios:

 if you want to use the Setup.msi file, rather than a start-up script, to
install the software by using a Group Policy Object

+ if you want to use the Setup.msi file to create packages for use with
Novell ZENworks Desktop Management

As with Setup.exe, you use msiexec.exe to create command lines that

perform a setup-related function. A msiexec.exe command line

requires the following items:

+ a switch that signals the desired action: installing (/1), repairing (/
f), or removing (/X) the software

* the location and name of the desired MSI file: typically, Setup.msi
(located on the installation disc or the media you copied or extracted
to the server).

* any desired public properties

* any desired switches, as specified by the
CHAINER_CMD=""switches" public property (multiple switches are
separated by a space)

For example, the following msiexec.exe command line uses the file
\\server\WPQ18\Setup.msi to install the software while displaying the
full user interface:

msiexec.exe /i "\\server\WPO\Setup.msi"
ADDLOCAL=""ALL" CHAINER_CMD=""/qf"

As previously explained (see page 31), you can use the TRANSFORMS
public property to apply an MST file to the setup. By default, all MST
files are applied to the Setup.msi file. If you want to apply an MST file
to a different MSI file, you must use the following syntax (where MSI
is the filename of the MSI file, not including its extension; and where
MST is the filename of the MST file, including its extension):

TRANSFORMS_MSI=""MST"

If the MST file is not in the same folder as the MSI file, MST must
specify the full path and filename of the MST file.
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For example, the following msiexec.exe command line uses the file
\\server\WPO\Setup.msi to install the software silently, applies the
transformation my_wp.mst to WP.msi (in the same folder), and
applies the transformation my_qp.mst to QP.msi (in the same folder):

msiexec.exe /i "\\server\WPO\Setup.msi"
ADDLOCAL=""ALL"™ CHAINER_CMD=""/gn"
TRANSFORMS_WP=""my_wp.mst""
TRANSFORMS_QP="my_gp.mst"
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Deploying Paradox

You can make Paradox available on the workstations only if it is
included in your version of WordPerfect Office. However, please note
that the process for deploying Paradox is separate from the process for
deploying WordPerfect Office.

You can deploy Paradox regardless of whether you’re deploying
WordPerfect Office. However, if you want to deploy both, you must
deploy WordPerfect Office first and Paradox second.

For an overview of the deployment process for WordPerfect Office,
please see “Stage 1: Preparing for deployment” on page 2.

Copying or extracting the media for Paradox

The process for copying or extracting media for Paradox is similar to
the process for WordPerfect Office. Follow the procedures given on
page 6, but be sure to use the Paradox setup rather than the one for
WordPerfect Office.

Deploying Paradox to the workstations

The process for deploying Paradox to the workstations is similar to the
process for deploying WordPerfect Office — just be sure to use the
Paradox installation files rather than the ones for WordPerfect Office.
Default installation files are provided with the Paradox setup.

If you want to specify individual features in your command line, see
“Paradox command-line features” on page 38.

For information on pulling software to the workstations, see “Pulling
the software” on page 8.

For information on pushing software to the workstations, see “Pushing
the software” on page 9.

Optimizing the installed software

To optimize the installed software, you must refresh the New from
project template list in PerfectExpert.

In addition, in order for Paradox to function properly, you must ensure
that the network-folder settings for Borland Database Engine points to
a folder for which all users have write and delete permissions.
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Maintaining the software

To refresh the PerfectExpert template list
1 Click File » New from project.
2 In the PerfectExpert dialog box, click Options » Refresh project.

To change the network-folder settings

1 After installation, log on to the server console as an administrator.
2 From the Windows Control Panel, open the BDE Administrator.
3 Click the Configuration tab.
4

Expand the Configuration tree, and navigate to
Drivers\Native\PARADOX.

In the right pane, click the field to the right of the NET DIR entry.

6 Click ..., and browse to the location that you have chosen as the
network folder.

9]

7 All users must have write and delete permissions on this folder.
8 Click Object » Apply.

9 Click OK to confirm the save, and then click OK again when you
are prompted to restart all Borland Database Engine applications.

The process for maintaining the installed Paradox software is similar to
the process for maintaining the installed WordPerfect Office software
— just be sure to use the Paradox installation files rather than the ones
for WordPerfect Office. Default installation files are provided with the
Paradox setup.

For information on maintaining software, see “Updating the software”
on page 21.

Paradox command-line features

Li

-
»@\

This section outlines the command-line features available for Paradox.

Features are available for the following Paradox components:
» Paradox
» Borland Database Engine
 filters
+ templates and sample tables
* writing tools
» For a list of available public properties, see page 12.

&  Remember that feature names are case-sensitive.

Paradox

The Paradox feature installs the main program file for Paradox and
all related files that are essential for running Paradox.
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Borland Database Engine

Feature filters

The BorlandDatabaseEngine feature installs the files that are
required to run Borland Database Engine version 5.2.

The Fi lters feature lets you install the following parent features:

* GraphicsConversions — installs the graphics-conversion filters
* Spreadsheets — installs the spreadsheet filters

* TextConversions — installs the text-conversion filters

* WordProcessors — installs the word-processor filters

Graphics-conversion filters

The GraphicsConversions parent feature contains two sets of
graphics-conversion filters: BitmapGraphicConversions and
VectorGraphicConversions.

The BitmapGraphicConversions feature contains the following
bitmap-conversion filters.

Bitmap-conversion filter Feature name
BMP conversion BMP
CAL conversion CAL
CPT conversion CPT
GIF conversion GIF
ICO/COR conversion 1COCOR
IMG conversion IMG
JPEG conversion JPEG
MAC conversion MAC
PCD conversion PCD
PCT conversion PCT
PCX conversion PCX
PNG conversion PNG
PP4 conversion PP4
PSD conversion PSD
SCT conversion SCT
TGA conversion TGA
TIFF conversion TIFF

WordPerfect
OFFICE

Deployment Guide
Deploying Paradox 39



Bitmap-conversion filter Feature name

WI conversion Wi

The VectorGraphicConversions feature contains the following
vector-conversion filters.

Vector-conversion filter Feature name

CDR/CMX/CCX conversion CDRCCX

CDT conversion CDT
CGM conversion CGM
DRW conversion DRW
DXF conversion DXF
EMF conversion EMF
EPS conversion EPS
HPGLPLT conversion HPGLPLT
PIC conversion PIC
SVG/XML conversion SVGXML
WMF conversion WMF
WPG conversion WPG

Spreadsheet filters

The Spreadsheets feature contains the following feature:
MicrosoftExcel, which installs the Microsoft® Excel® spreadsheet
filter.

Text-conversion filters

The TextConversions feature contains the following text-
conversion filters.

Text-conversion filter Feature name
ASCII export ASCI IExport
Unicode® export UnicodeExport

Word-processor filters

The WordProcessors feature contains the following word-processor
filters.
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Templates and samples

Writing tools

Word-processor filter

Feature name

Microsoft Word 97/2000/2002
import

Word9720002002

Microsoft® Word 95 import

Word95Import

RTF import

RTF

WordPerfect 6.X Text import

WordPerfect6.XText

WordPerfect 6/7/8/9/10 import

WordPerfect6.X

The TemplatesandSamples feature contains the following templates

and samples.

Item

Feature name

database template for storing
information about valuable coins

CoinCollectionTemplate

database template for tracking
office equipment

OfficeEquipmentTemplate

sample application demonstrating ~ HerculesWebSample
Web Server Control
sample database demonstrating OceanLifeSamples

graphics in Paradox and ObjectPAL

sample tables for Paradox (original

versions)

ParadoxClassicSample

tutorial for ObjectPAL

ObjectPalTutorialFiles

The WritingTools11 feature contains the following feature:
English, which installs the spelling checker for English.
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